从 Cinema 4D 中导入对象

Unity 可直接导入 Cinema 4D 文件。开始时只需将 .c4d 文件放到工程的资源 ( Assets) 文件夹下。 切换回 Unity 时,场景自动导入并显示在工程视图 (Project view) 中。

要在 Unity 中查看模型,只需将其从工程视图 (Project View) 拖入场景视图 (Scene View) 中。

如果修改 .c4d 文件,Unity 会在保存文件时自动更新。

Unity 现在可导入

  1. 带位置、旋转、缩放的所有对象。轴心和名称 (Name) 也被导入。
  2. 带 UV 和法线的网格。
  3. 包含纹理及漫反射颜色的材质。每个网格有多种材质。
  4. 正向运动学 (FK) 动画(IK 须手动烘培)。
  5. 基于骨骼的动画。

Unity 此时不支持导入顶点动画 (PLA)。请使用基于骨骼的动画代替。

使用反向运动学 (IK) 的角色动画

如果使用反向运动学 (IK) 在 Cinema 4D 中制作角色动画,须在选择插件 (Plugins)->摩卡 (Mocca)->Cappucino 菜单前先烘培 IK。如果导入 Unity 前不烘培 IK,很可能只导入了动画定位点而非骨骼动画。

要求

如果机器上没有安装 Cinema 4D,但是要从另一台机器上导入 Cinema 4D 文件,可导出 FBX 格式,Unity 可直接导入该格式:

  1. 打开 Cinema 4D 文件
  2. 在 Cinema 4D 中选择文件 (File)->导出 (Export)->FBX 6.0
  3. 将导出的 fbx 文件放在 Unity 工程资源 (Assets) 文件夹下。Unity 会自动导入 fbx 文件。

提示

  1. 导入 Cinema 4D 文件时若要将导入速度提至最高:请打开 Cinema 4D 首选项(编辑 (Edit)->首选项 (Preferences))后选择 FBX 6.0 首选项。不勾选嵌入纹理 (Embed Textures) 选项。

导入过程背后(高级)

Unity 导入 Cinema 4D 文件时会自动安装 Cinema 4D 插件并在后台启动 Cinema 4D。之后,Unity 与 Cinema 4D 通信,将 .c4d 文件转成 Unity 可读取的格式。第一次导入 .c4d 文件且尚未打开 Cinema 4D 时,启动时间稍长,但后续导入 .c4d 会非常快。

Cinema 4D 10 支持

直接导入 .c4d 文件时,Unity 会在后台将 Cinema 4D 文件转成 FBX 格式。 Maxon 发布 Cinema 4D 10.0时,FBX 导出工具出现了许多问题。在 Cinema 4D 10.1 版本中许多问题得到了修正。因此,我们强烈建议 Cinema 4D 10 用户升级至 10.1 版本。

现在,Maxons FBX 导出工具中还存在一些问题。目前似乎没有一个可靠方法来导出带有 Cinema 4D 10 关节的动画角色,但在 9.6 版本中旧骨骼系统可完美导出。因此,创建动画角色时使用旧骨骼系统非常关键,而不要使用关节工具。

Page last updated: 2013-06-30