项目工程浏览器 (Project Browser)

在该视图中,您可以访问和管理属于工程的资源。

浏览器左侧的视图以层级列表的形式显示工程的文件夹结构。点击列表中的文件夹选定后,内容将显示在右侧视图中。单个资源显示为图标,标明其类型(脚本、材料、子文件夹等)。移动视图下方的滑块,可调整图标大小。如果滑块移至最左侧,会被层级列表视图替代。滑块左侧将显示当前选定的项目,包括项目的完整路径(如果正在进行搜索)。

工程结构列表上方是收藏夹 (Favorites) 部分,可将经常使用的项保存在此,便于以后访问。将工程结构列表中的项拖动至收藏夹 (Favorites),并在此保存搜索查询(见下方的搜索 (Searching))。

视图上方是“面包屑足迹 (breadcrumb trail)”,显示当前查看的文件夹路径。可以单击足迹的各单独元素,在文件夹层级视图 (hierarchy) 中轻松导航。搜索时,该栏变化,以显示搜索的区域(资源 (Assets) 根文件夹、选定文件夹或资源商店 (Asset Store))以及商店内许多免费和付费的资源,由斜杠分隔。Unity 偏好设置 (Preferences) 窗口的常规 (General) 部分有一个选项,可禁用资源商店 (Asset Store) 的点击计数显示(如果不需要)。

窗口上边缘是浏览器的工具栏。

创建 (Create) 菜单位于工具栏的左侧,可以给现有文件夹添加新资源和子文件夹。右侧是一组工具,供您搜索工程中的资源。

窗口 (Window) 菜单中有一个选项可供转换至工程视图单列版,基本上只有层级结构列表,无图标视图。菜单旁的锁定图标可“冻结 (freeze)” 视图中的当前内容(如防止被其他地方的事件更改),方式与检视器 (Inspector) 锁定类似。

搜索

浏览器拥有强大的搜索工具,在大工程或不熟悉的工程中查找资源时特别有用。基本搜索将根据搜索框中输入的文本筛选资源。

如果输入一个以上搜索词,搜索范围将缩小。如果输入海滨场景,就只会查找名称中带“海滨”和“场景”两个词的资源(如词汇之“和”)。

搜索栏右侧有三个按钮,第一个按钮让您可以根据类型进一步筛选搜索时找到的资源。

右侧第二个按钮根据标签 (Label) 筛选资源(可以在检视器 (Inspector) 中设置资源标签)。标签可能很多,因而标签菜单有单独的迷你搜索筛选框。

请注意,筛选器是通过在搜索文本中添加额外词进行筛选。以“t:”开头的词汇通过资源的具体类型进行筛选,而“l:”通过标签进行筛选。如果知道要查找的内容,可将这些词汇直接输入搜索框,而不使用菜单。一次可搜索一个以上的类型或标签。添加多个类型会扩大搜索范围,涵盖所有具体类型(如类型之“或”)。添加多个标签将缩小搜索范围,找出所有含有特定标签的选项(如标签之“和”)。

点击最右边的按钮将项添加至资源列表的收藏夹 (Favourites) 部分,保存该搜索。

搜索资源商店 (Asset Store)

项目工程浏览器 (Project Browser) 的搜索功能也可用于查找 Unity 资源商店 (Asset Store) 中可用的资源。如果从面包屑工具栏的菜单中选择资源商店 (Asset Store),将显示商店内符合查询条件的所有免费和付费项目。对于 Unity 工程来说,根据类型和标签搜索的方式相同。先将搜索词与资源名称核对,再按照资料包名称、资料包标签和资料包描述的顺序进行核对(因此,名称中包含搜索词的项目排在资料包描述中包含相同词汇的项目之前)。

如果从列表中选择项目,其详情将显示在检视器 (Inspector) 中,同时显示的还有购买和/或下载选项。部分资源类型可在该部分预览,可供购买前播放音频片段或转动三维模型。检视器 (Inspector) 还提供 在普通资源商店 (Asset Store) 窗口内查看资源的功能,以了解更多细节。

快捷方式

浏览器视图有焦点时下列快捷方式可用。请注意,部分快捷方式只有在视图使用双列布局时才可用(使用顶部右上角的视图菜单可在单列和双列布局之间转换)。

F选择帧
Tab在第一列和第二列之间转换焦点(两列)
Ctrl/Cmd + F焦点搜索框
Ctrl/Cmd + A选择列表中所有可见项目
Ctrl/Cmd + D复制所选资源
Delete跳出对话框后删除
Delete + Shift不跳出对话框而删除
Backspace + Cmd不跳出对话框而删除 (OSX)
Enter开始选定的重命名 (OSX)
Cmd + 向下键打开选定资源 (OSX)
Cmd + 向上键跳至父文件夹 (OSX,两列)
F2开始选定的重命名 (Win)
Enter打开选定资源 (Win)
Backspace跳至父文件夹 (Win,两列)
向右键展开选定项目(树形视图和搜索结果)。如果项目已展开,将选择其第一个子项。
向左键折叠选定项目(树形视图和搜索结果)。如果项目已折叠,将选择其父项。
Alt + 向右键预览资源时展开项目
Alt + 向左键预览资源时折叠项目

Page last updated: 2013-07-02