绑定工具

本页面的内容:

使用动画绑定工具集的过程的第一部分是创建初始骨骼。ART 使您能够快速生成并调整骨骼以填充角色的体积,甚至可以“草拟”角色的样子以便立即开始创建动画。

骨骼创建

下列步骤指导您创建角色的骨骼。

初始角色设置

  1. 要创建角色,请转到 Maya 界面中的 Epic 游戏(Epic Games)菜单,并选择 角色结构创建器(Character Rig Creator)

    ART_CreateCharacter.png

    如果 Maya 中的设置是设置为 Y 轴向上(默认值),那么系统将显示一个对话框,指出全局设置已调整为 Z 轴向上。这无非是为了与虚幻引擎的坐标空间保持一致。但是,视口可能会以奇怪的方式开始导览。这是 Maya 的行为,与此工具集无关。要解决此问题,请按 Alt-Home,或者 左键单击 鼠标悬停在 视图立方体(View Cube)上时显示的 起始位置(Home)按钮。

    ART_ViewCube.png

  1. 角色结构创建器界面在 UI 顶部显示了流程图,其中列出您所处的步骤以及后续步骤:

    ART_TopButtons.png

  2. 骨骼创建(Skeleton Creation)阶段,您可通过在每个肢体的各种字段中输入值来定义角色的关节设置。即使您需要添加额外的关节,也不必担心!我们很快就会说明如何完成该操作。此界面上的大部分内容相当直接了当。请输入您需要的脊柱关节数和手指关节数,等等。有几个奇妙的选项可加快您的创建过程。右腿和右臂都有可镜像左肢设置的复选框:

    ART_BoneSetup.png

当字段变为橙色时,表示值已更改为不同于工具的默认值。这无非是一种确定哪些值与默认值不同的简单方法。您随时可以通过 右键单击 肢体区域并选择 重置为默认值(Reset to Defaults).ART_ResetToDefaults.png 来重置为默认值。

添加额外的关节

要向角色添加额外的关节,请滚动并在 添加结构模块(Add Rig Modules)部分中选择要添加的结构模块:

ART_ExtraJoints.png

目前,您可以向角色添加三类额外关节。(随着时间推移,此列表会增大)

创建其中一个定制关节之后,它将显示在“骨骼设置”(Skeleton Setup)面板底部的 添加的模块(Added Modules)列表中。“添加的模块”(Added Modules)右侧显示所选模块的设置。这允许您更改已输入的初始设置,例如父代或关节数。

ART_CustomJointChains.png

要从此列表中移除任何已添加的模块,只需针对要移除的模块按 [Delete] 键。

您还可以为模块指定前缀或后缀命名约定。这将允许关节移动器对称模式(下一个步骤)以您指定的约定处理您所命名的模块。

ART_SkelCreationMirrorSettings.png

例如,我已添加两个本身作为骨盆子代的叶模块:[pouch_a_l] 和 [pouch_a_r]。因为我已使用镜像设置中指定的约定,所以当我在下一个步骤中开启对称模式时,这些模块将知道它们彼此互为镜像!

使用模板

您可以为骨骼创建设置保存模板,然后加载这些模板。

  1. 要保存模板,请进行您期望的设置,然后 左键单击 模板(Template)按钮并选择 保存(Save)

    ART_SaveLoad.png

  2. 要加载模板,请选择加载选项,然后从 UI 中选择模板:

    ART_LoadWindow.png

  3. 如果您希望移除某个模板,请选择要移除的模板,然后转到 文件(File)-> 移除选择的模板(Remove Selected Template)

    ART_RemoveTemplate.png

骨骼布置

您对骨骼设置感到满意后,便可以构建骨骼并将关节放入网格。

  1. 左键单击 UI 顶部的 骨骼布置(Skeleton Placement)按钮:

    ART_BuildSkel.png

  2. 这将构建所谓的 关节移动器。关节移动器是有序对象的结构,它使您能够在网格中快速布置关节。您会注意到,视口将显示替代网格,而不是显示典型的 Maya 关节。替代网格可以在没有最终资产的情况下草拟角色,这样动画制作者就可以立即开始工作。

    ART_JointMover.png

关节移动器 UI

关节移动器提供了控件选取器和定制大纲视图以及许多非常有用的工具来帮助您加快创建过程。我们将阐述左侧工具栏上的每个工具,并提供控件和选取器的简要说明。

ART_JointMover_UI.png

工具栏

工具栏包含设置角色骨骼和替代几何体所需的所有功能。

按钮 名称 说明
ART_button_SaveLoadTemplate.png 保存/加载模板(Save/Load Templates) 就像在骨骼创建工具中一样,您可以为关节位置保存模板,然后在其他角色上加载这些关节位置。这在角色需要共享骨骼的项目中非常有用。
ART_button_AimMode.png 目标模式(Aim Mode) 目标模式将使每个父代移动器以子代为目标,从而使您能够平移移动器并使父代始终指向子代。禁用目标模式将保留整个受影响的关节布置。
ART_button_SymmetryMode.png 对称模式(Symmetry Mode) 这种模式将使移动在角色的另一侧产生镜像。您可以在布置左侧之后开启此模式,以便将您的布置镜像到右侧,或者从一开始就开启此模式以便在布置期间实现实时对称。您会注意到,开启对称模式后,许多其他模式将变为禁用。禁用对称模式即可重新使用其他工具。禁用对称时,将会保留整个已镜像的关节布置。
ART_button_ResetToDefaults.png 重置为默认值(Reset to Defaults) 将整个关节移动器重置为原始创建姿势(进入场景时的姿势)。Ctrl + 鼠标左键 将仅重置当前选择的控件,而 Alt + 鼠标左键 将重置所选项及其下方的层次结构。
ART_button_GlobalMode.png 全局移动器模式(Global Mover Mode) 在此模式下,关节移动器将移动选定关节以及层次结构中位于其下方的所有内容。
ART_button_OffsetMode.png 偏移移动器模式(Offset Mover Mode) 在此模式下,关节移动器将仅移动选定关节,而不会移动任何其他内容。
ART_button_GeometryMode.png 几何体移动器模式(Geometry Mover Mode) 在此模式下,关节移动器将仅影响替代几何体,而不会影响任何关节布置。几何体移动器用来概略描述角色的比例和体积。
ART_button_ProxyPhysique.png 替代体形成形器(Proxy Physique Shaper) 显示一系列滑块,从而使您能够调整替代几何体的形状。以此方式,可修改身体的每个部分。这对于高度特化的类人形状非常有用。
ART_button_ToggleProxy.png 切换替代网格可见性(Toggle Proxy Mesh Visibility) 显示和隐藏替代几何体,这对于显示关节方向来说非常有用。
ART_button_Help.png 帮助(Help) 打开 docs.unrealengine.com 上的帮助文档。

关节移动器选择

工具栏旁边的大型角色图用来简化关节移动器的选择过程。左键单击 您希望移动的控件的位置即可将其选中。

ART_JointMoverSelection.png

请注意,当您单击黄色的控制选择框(例如手或脚)时,控制窗口将进行更新以显示该关节链,从而使您能够快速选择肢体末端和关节链部分,例如脊柱段、脚趾和手指。请注意,您执行此操作时,屏幕左上角将显示一个蓝色箭头,这使您可以通过 Web 浏览器样式的导航来返回到基本选择屏幕。

ART_HandJointMover.png

大纲视图

通过单击 UI 中的 大纲(Outliner)选项卡,您可访问关节移动器结构的定制大纲。单击任何条目都将选中 全局移动器(Global Mover)控件。单击所选项右侧的蓝色框将选中 偏移移动器(Offset Mover)控件。单击粉红色框将选中该所选项的 几何体移动器(Geometry Mover)控件。

ART_Outliner_View.png

锁定

在某些时候,您会希望使用对称模式或目标模式,但不希望这些功能影响特定关节。幸运的是,您可使用内置的 锁定(lock)功能来避免这种情况发生。您只需在大纲中选择不希望受影响的关节/移动器,然后 右键单击 并选择“锁定所选项”(Lock Selected):

ART_LockSelected.png

选择锁定某个所选项之后,您会注意到文本将变为斜体,并且名称旁边会出现红色圆圈,表示该项现已锁定。要进行解锁,您可以 右键单击 并选择“解锁所选项”(Unlock Selected)或“全部检索”(Unlock All)。

关节位置

在流程的现阶段,场景中实际上没有骨骼。在场景中,只有最终将会成为骨骼的内容表示。在这里,您在每个关节上看到的控件将准确指出最终关节的创建位置及其局部旋转轴。

ART_jointRep.png

如果您希望改为查看关节,可使用 关节移动器工具(Joint Mover Tools)菜单中的选项来构建预览骨骼:

ART_BuildPreviewSkeleton.png

这将运行用来创建最终骨骼的代码,以创建关节的临时预览。如果您愿意,可使用同一菜单来删除或重建预览骨骼。

烘培到全局

您可在 关节移动器工具(Joint Mover Tools)菜单下找到此工具:

ART_BakeToGlobal.png

此工具的作用是获取您对偏移移动器设置的所有值,改为将其烘培到全局移动器,从而将偏移移动器清零。这在您希望重新使用全新偏移时可能非常方便。 此功能还会在您使用 目标模式 时自动发生。您一旦关闭 目标模式,就会自动运行 烘培到全局,以将偏移控件中的值放入全局控件。

手脚枢轴

您可能会注意到一些控件似乎不会影响关节移动器结构上的任何关节位置。这些控件用于工具在构建结构时将会使用的手脚枢轴:

ART_PivotControls.png

这些枢轴将用于结构上的属性,例如手脚转动、侧向转动以及不同的枢轴旋转点:

ART_PivotExample.png

创建最终骨骼

完成使用关节移动器来放置关节之后,您可以按 UI 顶部的 变形设置(Deformation Setup)按钮,以使工具创建最终骨骼、允许您创建结构姿势,然后显示一些皮肤加权工具。

ART_SkinWeight.png

结构姿势

当您 左键单击 变形设置(Deformation Setup)按钮时,系统将显示几个对话框。第一个是“结构姿势”(Rig Pose)对话框:

ART_RigPoseDialog.png

结构姿势 是动画制作者所期望的开始姿势,这通常是 T 姿势 - 至少目前在 Epic 中如此。有时,因为拓扑流、参考材质、纹理处理甚至建模者个人喜好的原因,此姿势与角色的建模姿势有所不同。创建结构姿势的目的是缓解建模者偏爱某种姿势但动画制作者偏爱另一姿势这一问题。

如果您的模型已处于结构的首选姿势,请继续并单击 创建结构姿势(Create Rig Pose),但在下一个对话框上,当询问您是否希望工具将角色置于 T 姿势时,请按“否”。

您选择 创建结构姿势(Create Rig Pose)之后,将会显示另一个对话框,该话框询问是否要让工具尝试将角色置于预先定义的 T 姿势:

ART_AutoRigPose.png

您在此之后仍能够编辑结构姿势,此姿势无非是向您提供一个良好的起点。您也可以按“否”,并定义您所期望的开始结构姿势。

完成创建姿势后,请 左键单击 保存结构姿势(Save Rig Pose)按钮(此按钮将显示在它自己的对话框中)。

ART_CreateRigPoseDone.png

您可使用关节移动器工具来创建结构姿势。请勿担心,您的原始布置已存储并保留到 模型姿势(Model Pose)中。在皮肤加权过程中,您可在工具内通过 引用姿势管理器(Reference Pose Manager)菜单访问 模型姿势(Model Pose)结构姿势(Rig Pose)

保存结构姿势之后,系统将显示另一个对话框,该对话框会询问您是否希望对替代网格进行加权。此功能是可选的,如果您还没有最终模型,并且将使用替代网格来建立原型,那么建议您使用此功能:

ART_AutoSkin.png

对角色进行皮肤处理

对角色进行皮肤处理是默认的 Maya 工作流程。请选择新创建的 ART 关节(或根关节)以及您想要绑定的一个或多个网格,然后从“动画”(Animation)菜单集中选择 “皮肤”(Skin)菜单 -> 平滑绑定(Smooth Bind)-> 平滑绑定(Smooth Bind)

ART_NormalizeWeights_settings.png在 Maya 2013 中,“皮肤”(Skin)菜单 -> 平滑绑定(Smooth Bind)-> 平滑绑定选项(Smooth Bind Options)中默认的 规范化权重(Normalize Weights)选项设置为 后置(Post),这可能会产生一些令人沮丧的行为;为了最大限度地减少挫折,或者您希望采用旧版 Maya 中的行为,请将此选项设置为 交互式(Interactive)

皮肤加权工具

大体而言,皮肤加权 UI 与 Maya 的默认 UI 非常相似,只不过添加了许多工具和功能来加快您的工作流程。

ART_SkinningWindow.png

皮肤加权工具的工具栏

按钮 名称 说明
ART_button_PaintMode.png 绘制皮肤权重(Paint Skin Weights) 此按钮使用绘图工具,后者允许您在网格上绘制皮肤权重。基本上,这与 Maya 的“绘制皮肤权重工具”相同。
ART_button_ROM.png 运动范围(Range of Motion) 此按钮打开“运动范围”(Range of Motion)对话框,后者使您能够快速创建运动范围关键帧以测试皮肤处理。请参阅下文中的 运动范围 一节。
ART_button_TabSens.png 切换平板电脑灵敏度(Toggle Tablet Sensitivity) 此按钮执行切换,确定绘图模式是否利用平板电脑灵敏度。
ART_button_MirrorSkin.png 镜像皮肤权重(Mirror Skin Weights) 此按钮打开 Maya 的“镜像皮肤权重”(Mirror Skin Weights)命令的对话框。
ART_button_Prune.png 删除皮肤权重(Prune Skin Weights) 打开 Maya 的“删除权重”(Prune Weights)命令选项,从而使您能够清除不重要的权重值。这将清除轻微的皮肤处理错误。
ART_button_AddInfl.png 增加影响(Add Influence) 用来增加皮肤处理对几何体的影响。例如,您需要使用比默认情况下提供的关节数更多的关节来影响几何体。
ART_button_RemoveInfl.png 移除影响(Remove Influence) 允许您从某个几何体移除不需要的影响,例如不应使表面变形的骨骼。并且,可以自动移除权重为零的影响。
ART_button_ExportWeights.png 导出权重(Export Weights) 导出皮肤权重贴图。导出皮肤权重要求您指定文件名,并且将存储每个顶点的加权信息。
ART_button_ImportWeight.png 导入皮肤权重(Import Skin Weights) 这将显示用于选择皮肤权重文件的界面,并将这些权重值导入到相应的顶点上。
ART_button_Help.png 帮助(Help) 打开 docs.unrealengine.com 上的帮助文档。

绘制皮肤权重

工具设置

ART_SkinningToolSettings.png

“工具设置”(Tool Settings)区域包含 3 个主要区域:“轮廓”(Profile)、“皮肤工具”(Skin Tools)和“模式”(Mode)。

皮肤工具

按钮 名称 说明
ART_button_copyWeight.png 复制皮肤权重(Copy Skin Weight) 从选择的单一顶点复制皮肤权重。
ART_button_PasteWeight.png 粘贴皮肤权重(Paste Skin Weight) 将您从所选单一顶点复制的皮肤权重粘贴到任意数目的所选顶点。
ART_button_WeightHammer.png 锤子权重工具(Hammer Weights Tool) 此工具通过对选择的顶点指定本身为周围顶点的平均值的新权重值,快速清除表现出非预期行为的异常顶点。
ART_button_MoveInfluences.png 移动影响工具(Move Influences Tool) 此按钮用来将权重从一个影响转移到另一影响。
ART_button_ShowInflVerts.png 显示受影响顶点(Show Influenced Vertices) 突出显示选择的影响所影响的任何顶点。

模式

共有两种模式,即“绘制”和“选择”。与 Maya 的绘制权重工具不同,“选择”将为您提供更多非常有用的 UI 选项。

其中的大部分选择工具用于选择网格上的元素,并将所选项转换为顶点以方便批量处理,或者隔离该元素并返回到绘制模式以仅查看该元素。

选择

animationTool_ModeSelection_select.png

ART_SelectionTools.png

在此模式下,您可使用 Maya 的全套多边形选择工具。

名称 说明
从所选项中隔离元素(Isolate Element From Selection) 在已选择元件的情况下,这将选择 元素(附着面的集合)并切换 视图(View)-> 隔离所选项(Isolate Selection)-> 查看所选项(View Selection).单击后,此按钮将更改为 退出隔离模式(Exit Isolation Mode)
选择元素(Select Element) 根据任何已选择的元件,这将选择一个或多个 **元素*。
隔离所选项(Isolate Selection) 从所选项中隔离元素(Isolate Element From Selection)相似,但不会选择整个 元素,而是仅选择与元件相连接的面,然后切换 视图(View)-> 隔离所选项(Isolate Selection)-> 查看所选项(View Selection)。单击后,此按钮将更改为 退出手动隔离模式(Exit Manual Isolation Mode)
将所选项转换为顶点(Convert Selection To Verts) 在已选择面、边缘或 UV 的情况下,此按钮将所选项转换为顶点。

请勿 撤销 任何隔离选择模式,而应使用 退出隔离模式(Exit Isolation Mode)退出手动隔离模式(Exit Manual Isolation Mode)按钮。撤销 将结束 隔离所选项(Isolate Selection)-> 查看所选项(View Selected),但不会 撤销 对此按钮的单击,这将留下 退出(Exit)按钮,而您单击该按钮将重新开启 隔离所选项(Isolate Selection)-> 查看所选项(View Selected),但在未选择任何对象的情况下,屏幕显示就像是场景中的所有内容都已隐藏一样。此时,您可通过再次 撤销 来显示所有内容。

影响(绘制)

ART_ModeSelection.png

ART_skinning_InfluencesSection.png

直到您处于 绘制模式 ART_button_PaintMode.png 并选中已进行皮肤处理的几何体之后,在“影响列表”(Influence List)中才会填入内容。

“影响列表”(Influence List)可以按许多种方式进行排序,包括按影响名称排序或者仅显示已锁定或未锁定的影响:

绘制操作(Paint Operations)与 Maya 中的相应操作完全相同。

ART_Skin_PaintOps.png

对此工具进行的其他更改已添加到不透明度滑块和值滑块的快捷按钮中。这些按钮无非是对那些属性设置常用值的快捷方法。

ART_Skin_Opacity.png

显示设置

ART_Skin_DisplaySettings.png

名称 说明
绘制笔刷(Draw Brush) 切换权重笔刷的可见性。
显示线框(Show Wireframe) 切换模型线框的可见性。
颜色反馈(Color Feedback) 切换颜色反馈在皮肤上的可见性。

运动范围工具

“运动范围”(Range of Motion)按钮将打开“运动范围工具”(Range of Motion Tool),后者需要您特别加以注意。此工具将自动创建模型的运动范围动画,从而使您能够通过拖动时间滑块来测试皮肤加权质量。

ART_RangeOfMotion.png

界面由一个列表组成,其中包含骨骼中的所有关节。请选择您希望创建动画的关节,然后 左键单击 生成运动范围键(Generate Range of Motion Keys) 按钮。

如果您希望某些关节作为一个单元来旋转(例如样条的关节,它们通常不需要逐个旋转),请选择这些关节,并选中 解析为一个项(Solve as One Item)复选框。这可确保设置的每个键都用于整个样条姿势,而不是仅用于一个关节。

要移除运动范围动画(在构建控制结构前始终应该执行此操作),请 右键单击“运动范围”(Range of Motion)按钮,并选择清除选项:

参考姿势管理器

ART_ReferencePoseManager.png

名称 说明
采用模型姿势(Assume Model Pose) 骨骼将采用模型姿势,您可通过在“编辑布置”模式下编辑控制对象的旋转以及使用“重置模型姿势”(Reset Model Pose)来设置该姿势。
采用结构姿势(Assume Rig Pose) 骨骼将采用结构姿势,您可通过在“编辑布置”模式下编辑控制对象的旋转以及使用“重置结构姿势”(Reset Rig Pose)来设置该姿势。
重置模型姿势(Reset Model Pose) 此选项将模型姿势设置为控制对象当前所处的姿势。这在“编辑布置”模式下非常有用。
重置结构姿势(Reset Rig Pose) 此选项将结构姿势设置为控制对象当前所处的姿势。一旦离开“编辑布置”模式,系统就会询问是否要使用当前姿势作为结构姿势并记录最佳实践。此功能在“编辑布置”模式下最为有用。

构建控制结构

此刻,在您的这个强壮角色的大体轮廓中可能只有一批替代形状,或者已有关节完成皮肤处理的完全实现角色。无论是在哪一种情况下,现在都可以创建 控制结构

  1. 左键单击 构建控制结构(Build Control Rig)按钮

    ART_BuildControlRig_full.png

  2. 这将显示 发布角色(Publish Character)界面。

    ART_PublishCharacter_empty.png

    现在,您可选择项目以便将角色发布到其中,如果您还没有项目,那么只需单击项目下拉列表左侧的新建项目按钮:

    ART_AddNewProject.png

    然后,对角色指定名称,或者从列表中选择名称以覆盖该角色:

    ART_PublishCharacter_full.png

    对于希望通过 MEL 或 Python 脚本对结构添加自己的内容的用户,可以使用高级部分。这些内容可以是简单的改动,例如调整曲线上的 CV 比例,也可以是任何更加个性化或更加复杂的内容。您只需加载脚本文件,工具将在完成构建结构后执行该文件。如果因为任何原因而执行该文件失败,那么系统将发出通知,但仍然会在不使用该脚本的情况下构建该结构。

    ART_Advanced.png

  1. 下一步是为角色指定一个缩略图。请使用标准的 Maya 摄像机控件来操纵迷你视口,或使用左侧的控制按钮,来获得您希望使用的缩略图。满意后,请 左键单击 摄像机 按钮以捕获该缩略图。这将开始结构构建过程。

    ART_CharacterPortrait.png

  2. 整个过程通常会在不到 1 分钟时间内完成,完成后将显示 操作完成(Operation Complete)对话框。

    ART_OperationComplete.png

    您可通过单击每个文件路径旁的放大镜图标来查看已在驱动器上创建的文件。您也可以选择直接编辑结构文件,以进行您所期望的任何手动调整。

  3. 左键单击“关闭”(Close)之后,此场景将清除,而这与预期相符。

现在,角色已准备好建立动画,您可以在以下位置找到它的文件:

/MayaTools/General/ART/Projects/YourProject/ExportFiles

已创建一个在导出文件中引用的动画结构文件,它位于以下位置:

/MayaTools/General/ART/Projects/YourProject/AnimRigs

添加角色

发布角色后,或者,如果您是从源文件控制系统拉取角色的动画制作者,您可以将其引入场景以开始制作动画。要将角色添加到场景,请使用 “Epic 游戏”(Epic Games)菜单 -> 为动画添加角色(Add Character For Animation)菜单项。

ART_AddCharacter.png

您只需选择角色所在的项目,选择该角色本身,然后选择 添加(Add),或选择 添加并关闭(Add and Close)以便在添加角色后关闭 UI。

ART_AddCharacterUI.png

有关如何使用 ART 动画界面的更多信息,请参阅:动画工具

编辑角色

您可随时返回到管道并编辑关节的布置,甚至编辑骨骼设置以添加或移除关节。

另外,您可通过 构建控制结构(Build Control Rig)流程来编辑已发布的角色。

如果您正在处理场景,并需要使用 “Epic 游戏”(Epic Games)菜单 ->“编辑现有角色”(Edit Existing Character)选项来编辑角色,请勿忘记 保存场景。您选择编辑的角色将强制加载到 Maya 中,这将阻止当前场景中的任何进度。

在继续操作前,务必保存您的工作

要编辑已发布的角色,请转到 “Epic 游戏”(Epic Games)菜单 ->“动画绑定工具集”(Animation Rigging Toolset)->“编辑现有角色”(Edit Existing Character)

ART_EditCharacter.png

这将显示一个界面,以供您选择要编辑的角色。列表是工具所创建的所有导出文件的清单:

ART_EditCharacter_interface.png

您选择角色并 左键单击“编辑导出文件”(Edit Export File)之后,将打开该角色的导出文件并显示用于绑定管道的 UI。加载之后,您可使用“ART 绑定工具集”(ART Rigging Toolset)界面进行任何所需更改。如果您进行了任何除皮肤加权以外的更改,那么在完成编辑之后,请确保使用 构建控制结构(Build Control Rig)按钮重建控制结构。

Maya 的引用系统十分健壮,您可以进行所需的所有更改,而对流程中任何工作(动画、皮肤处理,等等)的影响将保持在最低限度。这假定未对结构的命名和组织进行重大更改,否则这些更改将在引用链中向上传播。

重大更改的一个示例如下:角色有尾巴,您重建尾巴,但指定了新名称。在这种情况下,这些关节的所有动画和皮肤处理数据都将丢失。

其他轻微更改可能仍要求重做动画。

角色加载之后,“ART 绑定工具集”(ART Rigging Toolset)将处于 变形设置(Deformation Setup)模式,但您可以切换回到 骨骼布置(Skeleton Placement)骨骼创建(Skeleton Creation)并进行任何所需的更改。

ART_EditCharacter_SkelPlac.png

如果从 皮肤权重(Skin Weight)模式进入 骨骼布置(Skeleton Placement)模式,并且已对骨骼进行网格皮肤处理(自动进行皮肤处理的替代几何体不算),那么系统会发出提示,指出工具将尽量存储皮肤数据,但并不是十分安全。

骨骼创建(Skeleton Creation)模式下添加的关节不会自动将其自身添加到先前用来对骨骼进行皮肤处理的角色网格的皮肤处理数据中。要添加这些关节,您只需使用 添加影响(Add Influences)按钮,然后从列表中选择新关节。

ART_AddInf.png

ART_AddInf_post.png

新关节一开始处于锁定状态,不会影响网格。

返回到 变形设置(Deformation Setup)模式后,保存的皮肤数据将重新应用于已进行皮肤处理的网格。

定制

为了帮助进行可视化,工具支持对替代几何体和用户界面图形进行定制。

关节移动器替代几何体的定制调色板

关节移动器替代几何体具有 UV,因此您可快速建立角色调色板原型。您可在下列位置找到 PSD: /UE4/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Icons/ART/jointMover.psd

这个 PSD 对所有部件都作了标注和颜色编码,以方便您进行选择和油漆桶填充:

ART_CharacterProxyUV.png

这允许您向关节移动器的部件添加定制色样,以定制外观或添加象征符号等内容:

ART_CharacterColorPrototyping.png

其他资源

要获取其他帮助,请参阅 Epic 游戏(Epic Games)-> 帮助(Help)-> 学习视频(Learning Videos)部分中的 学习视频(Learning Videos)

ART_Help.png

这将显示一系列视频,它们涵盖绑定和动画方面的主题:

ART_Videos.png